Symptoms
- uPerform client hangs and never creates the document nor does the recorder toolbar appear when an author launches uPerform client >selects New> Enter a name for the file >select recording> browses to a desired location and Clicks ok.
- uPerform client stalls when creating new documents/recordings if free text blocks in the template have images that were not added using the Format menu option.
- Will see the following error in the application.log:
Critical : Inner Html for the body cannot be set.
System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
at System.RuntimeType.ForwardCallToInvokeMember(String memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)
at mshtml.HTMLBodyClass.set_innerHTML(String )
at ANCILE.uPerform.Document.HtmlEditor.HtmlEditorControl.set_InnerHtml(String value)
at ANCILE.uPerform.Document.HtmlEditor.HtmlEditorControl.set_InnerHtml(String value)
at ANCILE.uPerform.UI.Editor.Template.BlocksTab.SingleBlockPanel.LoadHtml()
at ANCILE.uPerform.UI.Editor.Template.BlocksTab.SingleBlockPanel.txtSource_Leave(Object sender, EventArgs e)
Environment
- Product: uPerform
- Version: Cloud
Cause
This was identified as a defect
Resolution
This defect was fixed in the 5.43.82 update.
Defect Number
D-17877
This defect was fixed in the latest update to uPerform Cloud.